SSL Certificate Issues
Incident Report for PhoneBurner
Resolved
The issue with the SSL certificate has been resolved.
Posted 11 months ago. Sep 18, 2018 - 18:46 PDT
Investigating
We are currently investigating an issue with an SSL certificate error. You can choose "Advanced" and proceed to Phoneburner.com to bypass.
Posted 11 months ago. Sep 18, 2018 - 18:37 PDT
This incident affected: Website.