Website is currently degraded and not functional.

Incident Report for PhoneBurner

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 20:46 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2025 - 19:46 PDT

Update

We are continuing to work on a fix for the issue.
Posted Mar 26, 2025 - 19:36 PDT

Update

The team continues to investigate the issue. A new update will come shortly.
Posted Mar 26, 2025 - 19:17 PDT

Investigating

We are investigating the issue.
Posted Mar 26, 2025 - 18:56 PDT
This incident affected: Website, Dialer, API, and SMS.