Importer issue
Incident Report for PhoneBurner
Resolved
Importers are back to fully functional.
Posted 29 days ago. Jul 26, 2019 - 08:30 PDT
Investigating
We're investigating issues with the importer related to processing data.
Posted 29 days ago. Jul 26, 2019 - 08:16 PDT
This incident affected: Website.