Unable to Begin Dial Session
Incident Report for PhoneBurner
Resolved
The issue related to dial sessions ending early has been resolved. Please log out and log back into your account and begin a new dial session. Again, we sincerely apologize for any inconvenience this may have caused and appreciate your patience.
Posted over 1 year ago. Apr 05, 2018 - 08:55 PDT
Investigating
We are currently investigating a issue with users being unable to begin a dial session. We are pointing all resources to discovering and resolving the issue as soon as possible. We will update all of our users as soon as we know more.

Thank you for your patience.
Posted over 1 year ago. Apr 05, 2018 - 08:46 PDT