Call Quality Issues
Incident Report for PhoneBurner
Resolved
Call quality issues should now be resolved. If you are currently in a dial session, we recommend you end it and start a new one. You can finish any current dial session where you left off once you restart. If you continue to experience any issues, please contact our support team.
Posted Nov 26, 2019 - 11:00 PST
Investigating
This morning, we are receiving reports of various call quality issues. We are actively investigating and will provide more information soon. We apologize for any inconvenience.
Posted Nov 26, 2019 - 10:10 PST
This incident affected: Dialer.