Site response speed issues

Incident Report for PhoneBurner

Resolved

The site performance has been restored.
Posted Mar 14, 2025 - 13:05 PDT

Monitoring

We're observing site performance improvements. We're monitoring.
Posted Mar 14, 2025 - 12:58 PDT

Identified

We have identified the source of the issue and the team is working on resolution.
Posted Mar 14, 2025 - 12:48 PDT

Investigating

We are investing issues with the site loading slowly.
Posted Mar 14, 2025 - 12:44 PDT
This incident affected: Website and Dialer.