PhoneBurner slowdown
Incident Report for PhoneBurner
Resolved
We have identified and resolved the issue impacting performance. Everything is back to normal.
Posted May 29, 2020 - 13:05 PDT
Update
We are currently experiencing intermittent slowdowns and outages for some users. Thank you for your patience while we continue to troubleshoot this issue.
Posted May 29, 2020 - 12:40 PDT
Update
We are continuing to investigate this issue.
Posted May 29, 2020 - 12:35 PDT
Investigating
We are currently investigating intermittent slowdowns. Thank you for your patience.
Posted May 29, 2020 - 12:26 PDT
This incident affected: Website and Dialer.