Slow site performance
Incident Report for PhoneBurner
Resolved
We experienced an unusually high volume of traffic to portions of the site impacting performance for some users. We've identified the issue and sites are back to normal operation.
Posted 8 months ago. Dec 12, 2018 - 15:51 PST
Investigating
We're experiencing an issue impacting site performance. We're investigating.
Posted 8 months ago. Dec 12, 2018 - 15:37 PST
This incident affected: Website, Dialer, and API.