Degraded performance
Incident Report for PhoneBurner
Resolved
We experienced abnormally high traffic for a brief period that temporarily impacted performance. All systems are back to fully operational.
Posted 8 months ago. Jan 08, 2019 - 10:53 PST
Investigating
We're experiencing slow performance on our website. We're investigating the issue.
Posted 8 months ago. Jan 08, 2019 - 10:41 PST
This incident affected: Website, Dialer, and API.