Issues buying numbers and creating callerIDs

Incident Report for PhoneBurner

Resolved

This incident has been resolved.
Posted Dec 17, 2021 - 08:57 PST

Monitoring

We are seeing a recovery of services. We're waiting for the final all clear notification from the vendor before we close this incident. We'll post again once we know more.
Posted Dec 17, 2021 - 08:25 PST

Identified

We are experiencing issues with buying new vPhone numbers and verifying callerIDs. A 3rd party vendor is experiencing some issues that is impacting these parts of our product. We are monitoring the situation and will post an update as soon as we have more details.
Posted Dec 17, 2021 - 08:17 PST
This incident affected: Website.