Sitewide issues
Incident Report for PhoneBurner
Resolved
Sites are operational.
Posted Feb 17, 2021 - 12:41 PST
Monitoring
Sites are operational. We're researching the underlying issue and monitoring performance.
Posted Feb 17, 2021 - 12:19 PST
Investigating
Our servers are experiencing significant issues. We're investigating.
Posted Feb 17, 2021 - 11:41 PST
This incident affected: Website, Dialer, and API.