Website data
Incident Report for PhoneBurner
Resolved
Databases are caught up and back to fully operational. We will continue monitoring.
Posted over 1 year ago. May 01, 2018 - 12:11 PDT
Investigating
We're investigating reports of possible issues with the system. Some of our caching databases are slightly behind with getting updated data so the site might appear like data isn't saved properly.
Posted over 1 year ago. May 01, 2018 - 11:59 PDT
This incident affected: Website.