Site performance issues

Incident Report for PhoneBurner

Resolved

Site performance has been fully restored.
Posted Apr 03, 2025 - 10:03 PDT

Monitoring

We are observing improved performance. The team is continuing to monitor.
Posted Apr 03, 2025 - 09:53 PDT

Investigating

We are investigating site performance issues
Posted Apr 03, 2025 - 09:41 PDT
This incident affected: Website, Dialer, and API.