Site down
Incident Report for PhoneBurner
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 00:08 PDT
Monitoring
Sites are coming back online. We're monitoring.
Posted Jun 21, 2022 - 00:06 PDT
Investigating
Our site is protected by Cloudflare and they are experiencing a service outage. Major services around the world are impacted. We are researching.

Here is the link to the Cloudflare status page:
https://www.cloudflarestatus.com/incidents/xvs51y9qs9dj
Posted Jun 20, 2022 - 23:49 PDT
This incident affected: Website, Dialer, and API.