Website outage
Incident Report for PhoneBurner
Postmortem

Overview

At 8:15am PT the website experienced a full outage where all site traffic including dialer actions were impacted. The downtime lasted for roughly 15 minutes.

The operations team was alerted to the issue and immediately began investigating.

Cause

The website's connection to the database is critical to its operation. The database connection management software went into failure which caused our website servers to stop answering web requests. As a result, all visitors saw a 503 error instead of the normal website.

Resolution

The issue was resolved once the connection management software component was restarted. Websites began responding immediately. The operations team is investigating a plan to improve how our software handles this issues.

Impact

Full site outage for roughly 15 minutes.

Posted about 2 years ago. Aug 24, 2017 - 09:05 PDT

Resolved
The issue has been resolved -- PhoneBurner is now operating at 100%.
Posted about 2 years ago. Aug 24, 2017 - 08:33 PDT
Monitoring
The database connections are reconnected and the site is back up. We're monitoring.
Posted about 2 years ago. Aug 24, 2017 - 08:31 PDT
Identified
We're still investigating, but appears there is an issue with some of the core database connections. We're still researching the details.
Posted about 2 years ago. Aug 24, 2017 - 08:30 PDT
Investigating
We're experiencing an issue with the website. We're investigating.
Posted about 2 years ago. Aug 24, 2017 - 08:20 PDT