Call quality
Incident Report for PhoneBurner
Resolved
Calls from an upstream phone company appear to be providing poor call quality. We've routed calls away from those carriers and things should be back to normal. While the issue appears to be resolved, we'll continue to monitor the situation and reopen an incident as needed.
Posted over 1 year ago. Feb 28, 2018 - 16:24 PST
Investigating
We're investigating reports of degraded call quality.
Posted over 1 year ago. Feb 28, 2018 - 16:05 PST