Website performance degradation

Incident Report for PhoneBurner

Resolved

Site performance is back to normal operation.
Posted Jul 28, 2025 - 11:25 PDT

Monitoring

Site performance is improving. We're monitoring.
Posted Jul 28, 2025 - 11:23 PDT

Investigating

We are investigating performance issues with the website.
Posted Jul 28, 2025 - 11:20 PDT
This incident affected: Website, Dialer, and API.