Temporary outage

Incident Report for PhoneBurner

Resolved

The issue has been resolved. If you are still experiencing issues, reach out to our support team.
Posted Mar 02, 2022 - 16:05 PST

Investigating

We are currently investigating the issue.
Posted Mar 02, 2022 - 15:57 PST
This incident affected: Website, Dialer, and API.