Site is down
Incident Report for PhoneBurner
Resolved
All systems are back online. We'll continue monitoring.
Posted Jul 13, 2020 - 13:42 PDT
Monitoring
Site is back online and functioning. We're in monitoring mode and will update again shortly with more details.
Posted Jul 13, 2020 - 13:28 PDT
Investigating
We are investigating issues with the site.
Posted Jul 13, 2020 - 13:09 PDT
This incident affected: Website, Dialer, and API.