Sites are not loading
Incident Report for PhoneBurner
Resolved
Sites are back to normal. We are monitoring.
Posted 6 months ago. Feb 28, 2019 - 09:11 PST
Investigating
We are experiencing issues with the website. We are researching.
Posted 6 months ago. Feb 28, 2019 - 09:01 PST
This incident affected: Website, Dialer, and API.