Contact data issue
Incident Report for PhoneBurner
Resolved
Issue has been fully resolved.
Posted 9 months ago. Nov 12, 2018 - 11:41 PST
Update
The fix is currently in progress. Those impacted will see their contacts showing up over the next several minutes. We'll update again in a few minutes.
Posted 9 months ago. Nov 12, 2018 - 11:24 PST
Identified
We have identified an issue where some contacts are disappearing from some accounts. We are aware of the issue and are working on it. No data has been lost, and will be restored shortly.
Posted 9 months ago. Nov 12, 2018 - 10:25 PST
This incident affected: Website.